Thread (17 messages) flat view 17 messages, 5 authors, 2025-06-02

Re: [RFC PATCH v1 3/6] mm: Avoid calling page allocator from apply_to_page_range()

From: Liam R. Howlett <hidden>
Date: 2025-05-30 19:10:28
Also in: linux-arm-kernel, linux-mm, lkml, sparclinux, virtualization, xen-devel

* Ryan Roberts [off-list ref] [250530 12:50]:
...
quoted

These wrappers are terrible for readability and annoying for argument
lists too.
Agreed.
quoted
Could we do something like the pgtbl_mod_mask or zap_details and pass
through a struct or one unsigned int for create and lazy_mmu?
Or just create some enum flags?
quoted
At least we'd have better self-documenting code in the wrappers.. and if
we ever need a third boolean, we could avoid multiplying the wrappers
again.

WDYT?
I'm happy with either approach. I was expecting more constination about the idea
of being able to disable lazy mode though, so perhaps I'll wait and see if any
arrives. If it doesn't... flags?
Yes, that works as well.  Please use pmd_flags or anything more
descriptive than just 'flags' :)

I wonder which approach is best in asm instructions and self-documenting
code.

Regards,
Liam

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help