On Tue, May 06, 2025 at 02:56:54PM +0200, Stefano Garzarella wrote:
On Wed, Apr 30, 2025 at 06:39:58PM +0300, Jarkko Sakkinen wrote:
quoted
On Mon, Apr 14, 2025 at 04:56:50PM +0200, Stefano Garzarella wrote:
quoted
From: Stefano Garzarella <sgarzare@redhat.com>
In preparation for the next commit, add a new `buf_size` parameter to
the `.send` callback in `tpm_class_ops` which contains the entire buffer
size. In this patch it is pretty much ignored by all drivers, but it will
be used in the next patch.
So instead "in preparation for the next commit" just plain say why it
will be needed. "next commit" is a fuzzy reference :-)
Same goes for "next patch". Neither can be used to query any possible
information. That sort of makes the whole paragraph useless, once it
is in the commit log.
Got it! What about somethig like this:
Add a new `buf_size` parameter to the `.send` callback in
`tpm_class_ops`. This parameter will allow drivers to differentiate
between the actual command length to send and the total buffer
size. Currently `buf_now` is not used, but it will be used to
support devices with synchronous `.send` callback to send the
command and receive the response on the same buffer.
definitely to right direction
Thanks,
Stefano
BR, Jarkko