Thread (31 messages) 31 messages, 7 authors, 2024-12-03

Re: [PATCH 22/22] jiffies: Define secs_to_jiffies()

From: Jeff Johnson <hidden>
Date: 2024-11-15 21:32:07
Also in: ath11k, ceph-devel, cocci, dri-devel, intel-xe, linux-block, linux-bluetooth, linux-mm, linux-s390, linux-scsi, linux-sound, linux-staging, linux-wireless, live-patching, lkml, netdev, netfilter-devel, xen-devel

On 11/15/2024 1:22 PM, Easwar Hariharan wrote:
secs_to_jiffies() is defined in hci_event.c and cannot be reused by
other call sites. Hoist it into the core code to allow conversion of the
~1150 usages of msecs_to_jiffies() that either:

 - use a multiplier value of 1000 or equivalently MSEC_PER_SEC, or
 - have timeouts that are denominated in seconds (i.e. end in 000)

It's implemented as a macro to allow usage in static initializers.

This will also allow conversion of yet more sites that use (sec * HZ)
directly, and improve their readability.

Suggested-by: Michael Kelley <redacted>
Signed-off-by: Easwar Hariharan <redacted>
Signed-off-by: Thomas Gleixner <redacted>
Reviewed-by: Luiz Augusto von Dentz <redacted>
Link: https://lore.kernel.org/all/20241030-open-coded-timeouts-v3-1-9ba123facf88@linux.microsoft.com (local)
your signed-off-by should be last.

and you have a patch ordering problem since this patch must come before all
the patches that use secs_to_jiffies(), otherwise this series cannot be bisected

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help