On Thu, Oct 10, 2024 at 09:01:30AM +0200, Thomas Weißschuh wrote:
From: Nam Cao <redacted>
The struct arch_vdso_data is only about vdso time data. So rename it to
arch_vdso_time_data to make it obvious.
Non time-related data will be migrated out of these structs soon.
Signed-off-by: Nam Cao <redacted>
---
arch/Kconfig | 2 +-
arch/riscv/Kconfig | 2 +-
arch/riscv/include/asm/vdso/{data.h => time_data.h} | 8 ++++----
arch/riscv/kernel/sys_hwprobe.c | 2 +-
arch/riscv/kernel/vdso/hwprobe.c | 4 ++--
arch/s390/Kconfig | 2 +-
arch/s390/include/asm/vdso/data.h | 12 ------------
arch/s390/include/asm/vdso/time_data.h | 12 ++++++++++++
include/vdso/datapage.h | 8 ++++----
9 files changed, 26 insertions(+), 26 deletions(-)
Acked-by: Heiko Carstens <hca@linux.ibm.com> # s390