On Thu, Apr 11, 2024 at 03:07:46PM +0200, Greg Kroah-Hartman wrote:
On Sat, Apr 06, 2024 at 03:52:00PM +0200, Lukas Wunner wrote:
quoted
For my upcoming PCI device authentication v2 patches, I have the need
to expose a simple buffer in virtual memory as a bin_attribute.
It turns out we've duplicated the ->read() callback for such simple
buffers a fair number of times across the tree.
So instead of reinventing the wheel, I decided to introduce a common
helper and eliminate all duplications I could find.
I'm open to a bikeshedding discussion on the sysfs_bin_attr_simple_read()
name. ;)
Seems like no one objects, should I just take this through my
driver-core tree for 6.10?
That would be awesome, thank you!
Lukas