Re: [RFC PATCH v3 1/8] mm: page_alloc: avoid merging non-fallbackable pageblocks with others.
From: David Hildenbrand <hidden>
Date: 2022-01-13 12:28:18
Also in:
linux-iommu, linux-mm, lkml, virtualization
On 13.01.22 12:36, Mike Rapoport wrote:
On Wed, Jan 12, 2022 at 11:54:49AM +0100, David Hildenbrand wrote:quoted
On 05.01.22 22:47, Zi Yan wrote:quoted
From: Zi Yan <ziy@nvidia.com> This is done in addition to MIGRATE_ISOLATE pageblock merge avoidance. It prepares for the upcoming removal of the MAX_ORDER-1 alignment requirement for CMA and alloc_contig_range(). MIGRARTE_HIGHATOMIC should not merge with other migratetypes like MIGRATE_ISOLATE and MIGRARTE_CMA[1], so this commit prevents that too. Also add MIGRARTE_HIGHATOMIC to fallbacks array for completeness. [1] https://lore.kernel.org/linux-mm/20211130100853.GP3366@techsingularity.net/ (local) Signed-off-by: Zi Yan <ziy@nvidia.com> --- include/linux/mmzone.h | 6 ++++++ mm/page_alloc.c | 28 ++++++++++++++++++---------- 2 files changed, 24 insertions(+), 10 deletions(-)...quoted
quoted
@@ -3545,8 +3553,8 @@ int __isolate_free_page(struct page *page, unsigned int order) struct page *endpage = page + (1 << order) - 1; for (; page < endpage; page += pageblock_nr_pages) { int mt = get_pageblock_migratetype(page); - if (!is_migrate_isolate(mt) && !is_migrate_cma(mt) - && !is_migrate_highatomic(mt)) + /* Only change normal pageblock */ + if (migratetype_has_fallback(mt)) set_pageblock_migratetype(page, MIGRATE_MOVABLE); }That part is a nice cleanup IMHO. Although the "has fallback" part is a bit imprecise. "migratetype_is_mergable()" might be a bit clearer. ideally "migratetype_is_mergable_with_other_types()". Can we come up with a nice name for that?migratetype_is_mergable() kinda implies "_with_other_types", no? I like migratetype_is_mergable() more than _has_fallback(). My $0.02 to bikeshedding :)
:) Yeah, for me migratetype_is_mergable() would also be good enough. I think I was at first thinking one could mistake it with a dedicated migratetype. But such functions are historically called is_migrate_cma/is_migrate_cma/.... -- Thanks, David / dhildenb