Re: [PATCH 1/3] powerpc: Define empty_zero_page[] in C
From: Michael Ellerman <hidden>
Date: 2021-06-18 04:22:52
Also in:
lkml
From: Michael Ellerman <hidden>
Date: 2021-06-18 04:22:52
Also in:
lkml
On Mon, 7 Jun 2021 10:56:04 +0000 (UTC), Christophe Leroy wrote:
At the time being, empty_zero_page[] is defined in each
platform head.S.
Define it in mm/mem.c instead, and put it in BSS section instead
of the DATA section. Commit 5227cfa71f9e ("arm64: mm: place
empty_zero_page in bss") explains why it is interesting to have
it in BSS.
Applied to powerpc/next.
[1/3] powerpc: Define empty_zero_page[] in C
https://git.kernel.org/powerpc/c/45b30fafe528601f1a4449c9d68d8ebe7bbc39ad
[2/3] powerpc: Define swapper_pg_dir[] in C
https://git.kernel.org/powerpc/c/e72421a085a8dc81c71b0daeb89612279c2c621c
[3/3] powerpc/32s: Rename PTE_SIZE to PTE_T_SIZE
https://git.kernel.org/powerpc/c/91e9ee7e949bff08cc3845a4811185e826b6e2f1
cheers