From: Lee Jones <hidden> Date: 2021-05-20 12:51:45
Fixes the following W=1 kernel build warning(s):
drivers/char/hw_random/pseries-rng.c:42: warning: Function parameter or member 'vdev' not described in 'pseries_rng_get_desired_dma'
Cc: Matt Mackall <redacted>
Cc: Herbert Xu <herbert@gondor.apana.org.au>
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Paul Mackerras <redacted>
Cc: Lijun Pan <redacted>
Cc: "Uwe Kleine-König" <redacted>
Cc: Tyrel Datwyler <tyreld@linux.ibm.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Michael Neuling <redacted>
Cc: linux-crypto@vger.kernel.org
Cc: linuxppc-dev@lists.ozlabs.org
Signed-off-by: Lee Jones <redacted>
---
drivers/char/hw_random/pseries-rng.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
On Thu, May 20, 2021 at 2:13 PM Lee Jones [off-list ref] wrote:
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
Lee Jones (16):
char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
char: pcmcia: cm4040_cs: Remove unused variable 'uc'
char: random: Include header containing our prototypes
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: applicom: Remove 3 unused variables 'ret' and 2 instances of
'byte_reset_it'
char: tpm: tpm1-cmd: Fix a couple of misnamed functions
char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
char: agp: backend: Demote some non-conformant kernel-doc headers
char: agp: frontend: Include header file containing our prototypes
char: agp: via-agp: Remove unused variable 'current_size'
char: hpet: Remove unused variable 'm'
char: agp: generic: Place braces around optimised out function in if()
char: agp: uninorth-agp: Remove unused variable 'size'
char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
char: mem: Provide local prototype for non-static function
Thanks a lot!
I've looked all the patches now and commented on patches 6 and 16.
With my comments addressed
Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Arnd
From: Lee Jones <hidden> Date: 2021-05-21 07:23:07
On Thu, 20 May 2021, Arnd Bergmann wrote:
On Thu, May 20, 2021 at 2:13 PM Lee Jones [off-list ref] wrote:
quoted
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
Lee Jones (16):
char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
char: pcmcia: cm4040_cs: Remove unused variable 'uc'
char: random: Include header containing our prototypes
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: applicom: Remove 3 unused variables 'ret' and 2 instances of
'byte_reset_it'
char: tpm: tpm1-cmd: Fix a couple of misnamed functions
char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
char: agp: backend: Demote some non-conformant kernel-doc headers
char: agp: frontend: Include header file containing our prototypes
char: agp: via-agp: Remove unused variable 'current_size'
char: hpet: Remove unused variable 'm'
char: agp: generic: Place braces around optimised out function in if()
char: agp: uninorth-agp: Remove unused variable 'size'
char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
char: mem: Provide local prototype for non-static function
Thanks a lot!
I've looked all the patches now and commented on patches 6 and 16.
With my comments addressed
Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Thanks Arnd.
Would it be possible for the remaining 14 patches to be taken in
please? I will work on the 2 Arnd commented on in due course and
resubmit them independently.
TIA.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
On Fri, May 21, 2021 at 08:22:36AM +0100, Lee Jones wrote:
On Thu, 20 May 2021, Arnd Bergmann wrote:
quoted
On Thu, May 20, 2021 at 2:13 PM Lee Jones [off-list ref] wrote:
quoted
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
Lee Jones (16):
char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
char: pcmcia: cm4040_cs: Remove unused variable 'uc'
char: random: Include header containing our prototypes
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: applicom: Remove 3 unused variables 'ret' and 2 instances of
'byte_reset_it'
char: tpm: tpm1-cmd: Fix a couple of misnamed functions
char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
char: agp: backend: Demote some non-conformant kernel-doc headers
char: agp: frontend: Include header file containing our prototypes
char: agp: via-agp: Remove unused variable 'current_size'
char: hpet: Remove unused variable 'm'
char: agp: generic: Place braces around optimised out function in if()
char: agp: uninorth-agp: Remove unused variable 'size'
char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
char: mem: Provide local prototype for non-static function
Thanks a lot!
I've looked all the patches now and commented on patches 6 and 16.
With my comments addressed
Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Thanks Arnd.
Would it be possible for the remaining 14 patches to be taken in
please? I will work on the 2 Arnd commented on in due course and
resubmit them independently.
On Fri, May 21, 2021 at 09:42:29AM +0200, Greg Kroah-Hartman wrote:
On Fri, May 21, 2021 at 08:22:36AM +0100, Lee Jones wrote:
quoted
On Thu, 20 May 2021, Arnd Bergmann wrote:
quoted
On Thu, May 20, 2021 at 2:13 PM Lee Jones [off-list ref] wrote:
quoted
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
Lee Jones (16):
char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
char: pcmcia: cm4040_cs: Remove unused variable 'uc'
char: random: Include header containing our prototypes
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: applicom: Remove 3 unused variables 'ret' and 2 instances of
'byte_reset_it'
char: tpm: tpm1-cmd: Fix a couple of misnamed functions
char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
char: agp: backend: Demote some non-conformant kernel-doc headers
char: agp: frontend: Include header file containing our prototypes
char: agp: via-agp: Remove unused variable 'current_size'
char: hpet: Remove unused variable 'm'
char: agp: generic: Place braces around optimised out function in if()
char: agp: uninorth-agp: Remove unused variable 'size'
char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
char: mem: Provide local prototype for non-static function
Thanks a lot!
I've looked all the patches now and commented on patches 6 and 16.
With my comments addressed
Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Thanks Arnd.
Would it be possible for the remaining 14 patches to be taken in
please? I will work on the 2 Arnd commented on in due course and
resubmit them independently.
Yes, I can queue them up, thanks.
Wait, I can take the ones for code that I maintain, not for others.
drivers/char/ is "fun" in that some subdirs have active
trees/maintainers that are not me and Arnd so they go to Linus through
other ways. I'll queue up the ones that I am "allowed" to and you will
get the emails from that.
thanks,
greg k-h
From: Lee Jones <hidden> Date: 2021-05-21 07:56:44
On Fri, 21 May 2021, Greg Kroah-Hartman wrote:
On Fri, May 21, 2021 at 09:42:29AM +0200, Greg Kroah-Hartman wrote:
quoted
On Fri, May 21, 2021 at 08:22:36AM +0100, Lee Jones wrote:
quoted
On Thu, 20 May 2021, Arnd Bergmann wrote:
quoted
On Thu, May 20, 2021 at 2:13 PM Lee Jones [off-list ref] wrote:
quoted
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
Lee Jones (16):
char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
char: pcmcia: cm4040_cs: Remove unused variable 'uc'
char: random: Include header containing our prototypes
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
char: applicom: Remove 3 unused variables 'ret' and 2 instances of
'byte_reset_it'
char: tpm: tpm1-cmd: Fix a couple of misnamed functions
char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
char: agp: backend: Demote some non-conformant kernel-doc headers
char: agp: frontend: Include header file containing our prototypes
char: agp: via-agp: Remove unused variable 'current_size'
char: hpet: Remove unused variable 'm'
char: agp: generic: Place braces around optimised out function in if()
char: agp: uninorth-agp: Remove unused variable 'size'
char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
char: mem: Provide local prototype for non-static function
Thanks a lot!
I've looked all the patches now and commented on patches 6 and 16.
With my comments addressed
Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Thanks Arnd.
Would it be possible for the remaining 14 patches to be taken in
please? I will work on the 2 Arnd commented on in due course and
resubmit them independently.
Yes, I can queue them up, thanks.
Wait, I can take the ones for code that I maintain, not for others.
drivers/char/ is "fun" in that some subdirs have active
trees/maintainers that are not me and Arnd so they go to Linus through
other ways. I'll queue up the ones that I am "allowed" to and you will
get the emails from that.
Understood, thanks.
Hopefully the other maintainers will be as on the ball as you are.
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog