Thread (23 messages) flat view 23 messages, 2 authors, 2021-03-17

Re: [PATCH 03/14] swiotlb: move orig addr and size validation into swiotlb_bounce

From: Konrad Rzeszutek Wilk <hidden>
Date: 2021-03-17 02:17:36
Also in: linux-iommu, xen-devel

On Mon, Mar 01, 2021 at 08:44:25AM +0100, Christoph Hellwig wrote:
Move the code to find and validate the original buffer address and size
from the callers into swiotlb_bounce.  This means a tiny bit of extra
work in the swiotlb_map path, but avoids code duplication and a leads to
a better code structure.

Reviewed-by: Konrad Rzeszutek Wilk <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help