Re: [PATCH v2 2/7] CMDLINE: drivers: of: ifdef out cmdline section
From: Christophe Leroy <hidden>
Date: 2021-03-09 07:37:41
Also in:
linux-devicetree, linux-mips, lkml
Le 09/03/2021 à 01:02, Daniel Walker a écrit :
quoted hunk ↗ jump to hunk
It looks like there's some seepage of cmdline stuff into the generic device tree code. This conflicts with the generic cmdline implementation so I remove it in the case when that's enabled. Cc: xe-linux-external@cisco.com Signed-off-by: Ruslan Ruslichenko <redacted> Signed-off-by: Daniel Walker <redacted> --- drivers/of/fdt.c | 12 ++++++++++++ 1 file changed, 12 insertions(+)diff --git a/drivers/of/fdt.c b/drivers/of/fdt.c index feb0f2d67fc5..e25240d84632 100644 --- a/drivers/of/fdt.c +++ b/drivers/of/fdt.c@@ -25,6 +25,7 @@ #include <linux/serial_core.h> #include <linux/sysfs.h> #include <linux/random.h> +#include <linux/cmdline.h> #include <asm/setup.h> /* for COMMAND_LINE_SIZE */ #include <asm/page.h>@@ -1050,6 +1051,16 @@ int __init early_init_dt_scan_chosen(unsigned long node, const char *uname, /* Retrieve command line */ p = of_get_flat_dt_prop(node, "bootargs", &l); + +#ifdef CONFIG_GENERIC_CMDLINE + /* + * The builtin command line will be added here, or it can override + * with the DT bootargs. + */ + cmdline_add_builtin(data, + (l > 0 ? p : NULL), /* This is sanity checking */ + COMMAND_LINE_SIZE);
I don't think the comment is needed. Without the comment, it should fit on a single line, would be better for readability and grepability.
quoted hunk ↗ jump to hunk
+#else if (p != NULL && l > 0) strlcpy(data, p, min(l, COMMAND_LINE_SIZE));@@ -1070,6 +1081,7 @@ int __init early_init_dt_scan_chosen(unsigned long node, const char *uname, strlcpy(data, CONFIG_CMDLINE, COMMAND_LINE_SIZE); #endif #endif /* CONFIG_CMDLINE */ +#endif /* CONFIG_GENERIC_CMDLINE */ pr_debug("Command line is: %s\n", (char *)data);
Christophe