Thread (11 messages) 11 messages, 5 authors, 2021-03-27

Re: [PATCH 4/4] exec: move the call to getname_flags into do_execveat

From: Arnd Bergmann <arnd@arndb.de>
Date: 2021-03-26 15:13:36
Also in: linux-arch, linux-arm-kernel, linux-fsdevel, linux-mips, linux-s390, lkml, sparclinux

On Fri, Mar 26, 2021 at 3:38 PM Christoph Hellwig [off-list ref] wrote:
Remove the duplicated copying of the pathname into the common helper.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Looks correct, but
-static int do_execveat(int fd, struct filename *filename,
+static int do_execveat(int fd, const char __user *pathname,
                const char __user *const __user *argv,
                const char __user *const __user *envp, int flags)
Maybe rename this to ksys_execveat() for consistency now? I think that
is the current trend for functions that are essentially just the syscall.

With or without that change

Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help