Hi,
Thanks for the report.
* kernel test robot [off-list ref] [2020-12-03 07:25:06]:
tree: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git next-test
head: fb003959777a635dea8910cf71109b612c7f940c
commit: 77354ecf8473208a5cc5f20a501760f7d6d631cd [121/184] powerpc: Rename is_kvm_guest() to check_kvm_guest()
Sorry for the nit pick, but the commit should have been
Commit 107c55005fbd ("powerpc/pseries: Add KVM guest doorbell restrictions")
because thats the patch that introduced is_kvm_guest.
my patch was just renaming is_kvm_guest to check_kvm_guest.
config: powerpc-randconfig-c003-20201202 (attached as .config)
compiler: powerpc64le-linux-gcc (GCC) 9.3.0
If you fix the issue, kindly add following tag as appropriate
Reported-by: kernel test robot <redacted>
"coccinelle warnings: (new ones prefixed by >>)"
quoted
quoted
arch/powerpc/kernel/firmware.c:31:9-10: WARNING: return of 0/1 in function 'check_kvm_guest' with return type bool
Please review and possibly fold the followup patch.
But I agree we can still fold this the followup patch into the
Rename is_kvm_guest() to check_kvm_guest().
---
0-DAY CI Kernel Test Service, Intel Corporation
https://lists.01.org/hyperkitty/list/kbuild-all@lists.01.org
--
Thanks and Regards
Srikar Dronamraju