Thread (3 messages) flat view 3 messages, 2 authors, 2020-11-09

Re: [PATCH v2 00/23] Rid W=1 warnings in MTD

From: Miquel Raynal <miquel.raynal@bootlin.com>
Date: 2020-11-09 08:29:15
Also in: dri-devel, linux-media, linux-samsung-soc, lkml

Hi Lee,

Lee Jones [off-list ref] wrote on Fri,  6 Nov 2020 21:36:32
+0000:
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.

v1 => v2:
  - Added tags
  - Satisfied Miquel's review comments
You probably missed my request to update the titles. That's why I
wanted the entire series to be resent. Anyway, as I forgot a few,
please find below the prefixes that should be used:
Lee Jones (23):
  mtd: mtdpart: Fix misdocumented function parameter 'mtd'
  mtd: devices: phram: File headers are not good candidates for
    kernel-doc
  mtd: nand: onenand: onenand_base: Fix expected kernel-doc formatting
mtd: onenand: Fix...
  mtd: devices: docg3: Fix kernel-doc 'bad line' and 'excessive doc'
    issues
  mtd: mtdcore: Fix misspelled function parameter 'section'
mtd: Fix...
  mtd: nand: onenand: onenand_bbt: Fix expected kernel-doc formatting
mtd: onenand: Fix...
  mtd: spi-nor: controllers: hisi-sfc: Demote non-conformant kernel-doc
mtd: spi-nor: hisi-sfc: Demote...
  mtd: ubi: build: Document 'ubi_num' in struct mtd_dev_param
  mtd: nand: spi: toshiba: Demote non-conformant kernel-doc header
mtd: spinand: toshiba: Demote...
  mtd: ubi: kapi: Correct documentation for 'ubi_leb_read_sg's 'sgl'
    parameter
  mtd: ubi: eba: Fix a couple of misdocumentation issues
  mtd: ubi: wl: Fix a couple of kernel-doc issues
  mtd: nand: raw: brcmnand: brcmnand: Demote non-conformant kernel-doc
    headers
mtd: rawnand: brcmnand: Demote...
  mtd: ubi: gluebi: Fix misnamed function parameter documentation
  mtd: nand: raw: diskonchip: Marking unused variables as
    __always_unused
mtd: rawnand: diskonchip: Marking...
  mtd: nand: raw: cafe_nand: Remove superfluous param doc and add
    another
mtd: rawnand: cafe: Remove
  mtd: nand: raw: s3c2410: Add documentation for 2 missing struct
    members
mtd: rawnand: s3c2410: Add...
  mtd: nand: raw: omap_elm: Finish half populated function header,
    demote empty ones
mtd: rawnand: omap_elm: Finish
  mtd: nand: raw: omap2: Fix a bunch of kernel-doc misdemeanours
mtd:r rawnand: omap2: Fix
  mtd: nand: raw: sunxi_nand: Document 'sunxi_nfc's 'caps' member
mtd: rawnand: sunxi: Document
  mtd: nand: raw: arasan-nand-controller: Document 'anfc_op's 'buf'
    member
mtd: rawnand: arasan: Document
  mtd: nand: onenand: onenand_base: Fix some kernel-doc misdemeanours
mtd: onenand: Fix
  mtd: devices: powernv_flash: Add function names to headers and fix
    'dev'
Otherwise the content of the series looks good to me.

Thanks,
Miquèl
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help