Thread (47 messages) 47 messages, 6 authors, 2020-11-12

Re: [patch V3 05/37] asm-generic: Provide kmap_size.h

From: Arnd Bergmann <arnd@kernel.org>
Date: 2020-11-03 12:25:52
Also in: dri-devel, intel-gfx, linux-btrfs, linux-fsdevel, linux-mips, linux-mm, lkml, nouveau, sparclinux

On Tue, Nov 3, 2020 at 10:27 AM Thomas Gleixner [off-list ref] wrote:
kmap_types.h is a misnomer because the old atomic MAP based array does not
exist anymore and the whole indirection of architectures including
kmap_types.h is inconinstent and does not allow to provide guard page
debugging for this misfeature.

Add a common header file which defines the mapping stack size for all
architectures. Will be used when converting architectures over to a
generic kmap_local/atomic implementation.

The array size is chosen with the following constraints in mind:

    - The deepest nest level in one context is 3 according to code
      inspection.

    - The worst case nesting for the upcoming reemptible version would be:

      2 maps in task context and a fault inside
      2 maps in the fault handler
      3 maps in softirq
      2 maps in interrupt

So a total of 16 is sufficient and probably overestimated.

Signed-off-by: Thomas Gleixner <redacted>
Acked-by: Arnd Bergmann <arnd@arndb.de>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help