Thread (32 messages) 32 messages, 5 authors, 2020-07-02

Re: rename ->make_request_fn and move it to the block_device_operations

flat view

From: Jens Axboe <axboe@kernel.dk>
Date: 2020-06-30 13:57:36
Also in: dm-devel, linux-bcache, linux-m68k, linux-nvme, linux-raid, linux-s390, lkml, nvdimm

On 6/29/20 1:39 PM, Christoph Hellwig wrote:
Hi Jens,

this series moves the make_request_fn method into block_device_operations
with the much more descriptive ->submit_bio name.  It then also gives
generic_make_request a more descriptive name, and further optimize the
path to issue to blk-mq, removing the need for the direct_make_request
bypass.
Looks good to me, and it's a nice cleanup as well. Applied.

-- 
Jens Axboe
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help