On Sat, 15 Jun 2019 10:06:54 +0200 Christophe Leroy [off-list ref] wrote:
Le 14/06/2019 à 21:00, Andrew Morton a écrit :
quoted
On Fri, 14 Jun 2019 12:01:09 +0200 David Hildenbrand [off-list ref] wrote:
quoted
We are using a mixture of "int" and "unsigned long". Let's make this
consistent by using "unsigned long" everywhere. We'll do the same with
memory block ids next.
...
- int i, ret, section_count = 0;
+ unsigned long i;
...
- unsigned int i;
+ unsigned long i;
Maybe I did too much fortran back in the day, but I think the
expectation is that a variable called "i" has type "int".
This?
s/unsigned long i/unsigned long section_nr/
From my point of view you degrade readability by doing that.
section_nr_to_pfn(mem->start_section_nr + section_nr);
Three times the word 'section_nr' in one line, is that worth it ? Gives
me headache.
Codying style says the following, which makes full sense in my opinion:
LOCAL variable names should be short, and to the point. If you have
some random integer loop counter, it should probably be called ``i``.
Calling it ``loop_counter`` is non-productive, if there is no chance of it
being mis-understood.
Well. It did say "integer". Calling an unsigned long `i' is flat out
misleading.
What about just naming it 'nr' if we want to use something else than 'i' ?
Sure, that works.