Thread (16 messages) flat view 16 messages, 6 authors, 2019-06-11

Re: [RFC V3] mm: Generalize and rename notify_page_fault() as kprobe_page_fault()

From: Dave Hansen <hidden>
Date: 2019-06-10 04:57:33
Also in: linux-arm-kernel, linux-mips, linux-mm, linux-s390, linux-sh, lkml, sparclinux

On 6/9/19 9:34 PM, Anshuman Khandual wrote:
quoted
Do you really think this is easier to read?

Why not just move the x86 version to include/linux/kprobes.h, and replace
the int with bool?
Will just return bool directly without an additional variable here as suggested
before. But for the conditional statement, I guess the proposed one here is more
compact than the x86 one.
FWIW, I don't think "compact" is generally a good goal for code.  Being
readable is 100x more important than being compact and being un-compact
is only a problem when it hurts readability.

For a function like the one in question, having the individual return
conditions clearly commented is way more important than saving 10 lines
of code.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help