Re: powerpc/pseries/mce: Improve array initialization.

From
Michael Ellerman <hidden>
Date
2019-04-21 14:51:01
Reply to
Mahesh J Salgaonkar, 2019-03-28
On Thu, 2019-03-28 at 11:40:33 UTC, Mahesh J Salgaonkar wrote:
From: Mahesh Salgaonkar <redacted>

This is a follow up to the patch that fixed misleading print for TLB
mutlihit due to wrongly populated mc_err_types[] array. Convert all the
static array initialization to '[x] = val' style for better
readability of array indexing and avoid any further confusion.

Suggested-by: Michael Ellerman <mpe@ellerman.id.au>
Signed-off-by: Mahesh Salgaonkar <redacted>
Applied to powerpc next, thanks.

https://git.kernel.org/powerpc/c/c9d8dda42372dce00ac3a1c653bef7b8

cheers
Thread (2 messages) 2 messages, 2 authors, last reply 2019-04-21
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help