Re: [PATCH v3 01/10] VAS: Define macros, register fields and structures
From: Sukadev Bhattiprolu <hidden>
Date: 2017-03-30 21:35:46
Sukadev Bhattiprolu [sukadev@linux.vnet.ibm.com] wrote:
Michael Neuling [mikey@neuling.org] wrote:quoted
On Thu, 2017-03-16 at 20:33 -0700, Sukadev Bhattiprolu wrote:quoted
Define macros for the VAS hardware registers and bit-fields as well as couple of data structures needed by the VAS driver. =20quoted
Signed-off-by: Sukadev Bhattiprolu <redacted>--- Changelog[v3] - Rename winctx->pid to winctx->pidr to reflect that its a value =A0=A0from the PID register (SPRN_PID), not the linux process id. - Make it easier to split header into kernel/user parts - To keep user interface simple, use macros rather than enum for =A0=A0the threshold-control modes. - Add a pid field to struct vas_window - needed for user space =A0=A0send windows. =20 Changelog[v2] - Add an overview of VAS in vas-internal.h - Get window context parameters from device tree and drop =A0=A0unnecessary macros. --- =A0MAINTAINERS=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=
=A0=A0=A0|=A0=A0=A06 +
quoted
quoted
=A0arch/powerpc/include/asm/vas.h=A0=A0|=A0=A043 +++++ =A0drivers/misc/vas/vas-internal.h | 392 ++++++++++++++++++++++++++++=
++++++++++++
quoted
=20 This is going to have to go through gregkh/lkml if it's drivers/misc. =
you'll at
quoted
least need gregkh's ack/ok before mpe will take them (which is what we =
did for
quoted
CAPI). =20 We might want to keep this in arch/powerpc but I'm not sure. =20=20 We will have device nodes accessible to user space so put it here and can copy Gregkh next time. But let me know if we should move to arch/powerpc. =20
Thinking about this some more, the VAS module itself does not provide the device nodes. Rather, the drivers that use VAS, like NX-GZIP, will provide them. So, I am moving the VAS code into arch/powerpc/kernel. Please let me know of any comments/concerns. Thanks Suka