Thread (20 messages) 20 messages, 3 authors, 2017-02-15

Re: [PATCH v6 00/12]powerpc: "paca->soft_enabled" based local atomic operation implementation

flat view

From: Michael Ellerman <mpe@ellerman.id.au>
Date: 2017-02-08 12:44:32

Madhavan Srinivasan [off-list ref] writes:
Hi mpe,

Any update on this series. Have also fixed the naming issue with patch 12
and with this series applied,

"paca->soft_enabled"  becomes "paca->soft_disabled_mask"
Yeah sorry I've been putting off dealing with it.

Ideally we'd do the naming change earlier in the series, but maybe
that's not worth it.

The one thing I wanted to make sure was that regs->softe is never
exposed to userspace. Because we're changing its semantics, and user
space has no business knowing about it.

So I just checked the code, and we do allow userspace to see the softe
value. So I think we should fix that before this goes in.

The safest option is to just hardwire it to 1, as that's the value it
should always have in a userspace pt_regs.

cheers
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help