On Wed, Jan 25, 2017 at 01:27:22PM +0100, Thomas Huth wrote:
The function kvmppc_handle_exit_pr() is quite huge and thus hard to read,
and even contains a "spaghetti-code"-like goto between the different case
labels of the big switch statement. This can be made much more readable
by moving the code related to injecting program interrupts / instruction
emulation into a separate function instead.
Signed-off-by: Thomas Huth <redacted>
Thanks, applied to my kvm-ppc-next branch.
Paul.