On 12/19/2016 02:34 PM, Aneesh Kumar K.V wrote:
Reza Arbab [off-list ref] writes:
quoted
quoted
Add the linear page mapping function for radix, used by memory hotplug.
This is similar to vmemmap_populate().
Ok with this patch your first patch becomes useful. Can you merge that
with this and rename mmu_linear_psize to mmu_hotplug_psize or even use
mmu_virtual_psize. The linear naming is confusing.
mmu_linear_psize variable was referring to the page size used to create
kernel linear mapping (the 0xc00.... range) for the newly added memory
section. Why the name should be changed ?