On Sun, Sep 25, 2016 at 1:36 PM, Reza Arbab [off-list ref] wrote:
quoted hunk ↗ jump to hunk
In __fdt_scan_reserved_mem(), the availability of a node is determined
by testing its "status" property.
Move this check into its own function, borrowing logic from the
unflattened version, of_device_is_available().
Another caller will be added in a subsequent patch.
Signed-off-by: Reza Arbab <redacted>
---
drivers/of/fdt.c | 26 +++++++++++++++++++++++---
include/linux/of_fdt.h | 2 ++
2 files changed, 25 insertions(+), 3 deletions(-)
diff --git a/drivers/of/fdt.c b/drivers/of/fdt.c
index 085c638..9241c6e 100644
--- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c
@@ -151,6 +151,23 @@ int of_fdt_match(const void *blob, unsigned long node,
return score;
}
+bool of_fdt_is_available(const void *blob, unsigned long node)
of_fdt_device_is_available
[...]
+bool __init of_flat_dt_is_available(unsigned long node)
And of_flat_dt_device_is_available
With that,
Acked-by: Rob Herring <robh@kernel.org>