Excerpts from andrew.donnellan's message of 2016-07-13 15:52:45 +1000:
quoted
+bool _cxl_pci_associate_default_context(struct pci_dev *dev, struct cxl_afu *afu)
If we're sharing these functions between the vPHB and peer models, do we
have a better place than vphb.c for them?
Sure, I might split them out into a new phb.c for V3. It just seemed a
little pointless to create a new file for two functions at the time, but
you are right that they don't really belong in vphb.c. I guess an
alternative would be to rename vphb.c to phb.c, but 90% of that file is
vphb specific... I'll split these out.
quoted
+{
+ struct cxl_context *ctx;
+
+ /*
+ * Allocate a context to do cxl things too. This is used for interrupts
s/too/to/?
Heh, the one part of the comment that I didn't change from Mikey's code ;-P
Will fix.
Cheers,
-Ian