Thread (5 messages) 5 messages, 2 authors, 2016-05-10

Re: [2/2] powerpc/mm: Improve readability of update_mmu_cache()

flat view

From: Michael Ellerman <mpe@ellerman.id.au>
Date: 2016-05-10 21:48:38

On Fri, 2016-26-02 at 00:26:26 UTC, Gavin Shan wrote:
The function is used to update the MMU with software PTE. It can
be called by data access exception handler (0x300) or instruction
access exception handler (0x400). If the function is called by
0x400 handler , the local variable @access is set to _PAGE_EXEC
to indicate the software PTE should have that flag set. When the
function is called by 0x300 handler, @access is set to zero.

This improves the readability of the function by replacing if
statements with switch. No logical changes introduced.

Signed-off-by: Gavin Shan <redacted>
Applied to powerpc next, thanks.

https://git.kernel.org/powerpc/c/f3ad731cc08cc4fd3855f25c36

cheers
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help