Thread (50 messages) flat view 50 messages, 4 authors, 2016-02-23

Re: [PATCH V2 07/29] mm: Make vm_get_page_prot arch specific.

From: Aneesh Kumar K.V <hidden>
Date: 2016-02-15 04:40:33
Also in: linux-mm

Paul Mackerras [off-list ref] writes:
On Mon, Feb 08, 2016 at 02:50:19PM +0530, Aneesh Kumar K.V wrote:
quoted
With next generation power processor, we are having a new mmu model
[1] that require us to maintain a different linux page table format.

Inorder to support both current and future ppc64 systems with a single
kernel we need to make sure kernel can select between different page
table format at runtime. With the new MMU (radix MMU) added, we will
have to dynamically switch between different protection map. Hence
override vm_get_page_prot instead of using arch_vm_get_page_prot. We
also drop arch_vm_get_page_prot since only powerpc used it.
What's different about ISA v3.0 that means that the protection_map[]
entries need to be different?

If it's just different bit assignments for things like _PAGE_READ
etc., couldn't we fix this up at early boot time by writing new values
into protection_map[]?  Is there a reason why that wouldn't work, or
why you don't want to do that?
Yes, that is other way to do this. But I thought it is easier to have
different protection_map array for radix and hash. That made the code
more readable.

-aneesh
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help