Thread (19 messages) flat view 19 messages, 4 authors, 2016-02-09

Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header values

From: Tyrel Datwyler <hidden>
Date: 2016-02-09 18:27:20
Also in: linux-scsi, lkml

On 02/09/2016 09:41 AM, Manoj Kumar wrote:
quoted
Yeah, I can see how that is confusing. Since, all three possible valid
crq message types have the first bit set I think this was originally a
cute hack to grab anything that was likely valid. Then in
ibmvscsi_handle_crq() we explicitly match the full header value in a
switch statement logging anything that turned out actually invalid.
quoted
If 'valid' will only have one of these four enums defined, would
this be better written as:

	if (crq->valid != VIOSRP_CRQ_FREE)
This definitely would make the logic easier to read and follow. Also,
this would make sure any crq with an invalid header that doesn't have
its first bit set will also be logged by the ibmvscsi_handle_crq()
switch statement default block and not silently ignored.

-Tyrel
Sounds good, Tyrel. Does this mean I should expect a v2 of this patch
series?

- Manoj N. Kumar
Haven't had a chance to clean up and resubmit, but yes there will be a
v2 coming along soon.

-Tyrel
_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help