Re: [PATCH 1/2] mm: Replace nr_node_ids for loop with for_each_node in list lru
From: Raghavendra K T <hidden>
Date: 2015-09-14 11:38:48
Also in:
linux-mm, lkml
On 09/14/2015 02:30 PM, Vladimir Davydov wrote:
Hi, On Wed, Sep 09, 2015 at 12:01:46AM +0530, Raghavendra K T wrote:quoted
The functions used in the patch are in slowpath, which gets called whenever alloc_super is called during mounts. Though this should not make difference for the architectures with sequential numa node ids, for the powerpc which can potentially have sparse node ids (for e.g., 4 node system having numa ids, 0,1,16,17 is common), this patch saves some unnecessary allocations for non existing numa nodes. Even without that saving, perhaps patch makes code more readable.Do I understand correctly that node 0 must always be in node_possible_map? I ask, because we currently test lru->node[0].memcg_lrus to determine if the list is memcg aware.
Yes, node 0 is always there. So it should not be a problem.
quoted
Signed-off-by: Raghavendra K T <redacted> --- mm/list_lru.c | 23 +++++++++++++++-------- 1 file changed, 15 insertions(+), 8 deletions(-)diff --git a/mm/list_lru.c b/mm/list_lru.c index 909eca2..5a97f83 100644 --- a/mm/list_lru.c +++ b/mm/list_lru.c@@ -377,7 +377,7 @@ static int memcg_init_list_lru(struct list_lru *lru, bool memcg_aware) { int i; - for (i = 0; i < nr_node_ids; i++) { + for_each_node(i) { if (!memcg_aware) lru->node[i].memcg_lrus = NULL;So, we don't explicitly initialize memcg_lrus for nodes that are not in node_possible_map. That's OK, because we allocate lru->node using kzalloc. However, this partial nullifying in case !memcg_aware looks confusing IMO. Let's drop it, I mean something like this:
Yes, you are right. and we do not have to have memcg_aware check inside for loop too. Will change as per your suggestion and send V2. Thanks for the review.
static int memcg_init_list_lru(struct list_lru *lru, bool memcg_aware)
{
int i;
if (!memcg_aware)
return 0;
for_each_node(i) {
if (memcg_init_list_lru_node(&lru->node[i]))
goto fail;
}