Thread (18 messages) flat view 18 messages, 5 authors, 2015-03-10

Re: [RFC PATCH] powerpc/numa: reset node_possible_map to only node_online_map

From: Tejun Heo <tj@kernel.org>
Date: 2015-03-05 22:13:13

On Thu, Mar 05, 2015 at 10:05:49AM -0800, Nishanth Aravamudan wrote:
While looking at this, I noticed that nr_node_ids is actually a
misnomer, it seems. It's not the number, but the maximum_node_id, as
with sparse NUMA nodes, you might only have two NUMA nodes possible, but
to make certain loops work, nr_node_ids will be, e.g., 17. Should it be
changed?
It's the same for nr_cpu_ids.  It's counting the number of valid IDs
during that boot instance.  In the above case, whether the nodes are
sparse or not, there exist 17 node ids - 0 to 16.  Maybe numa_max_id
had been a better name (but would that equal the highest number or
+1?) but nr_node_ids != nr_nodes so I don't think it's a misnomer
either.  Doesn't really matter at this point.  Maybe add comments on
top of both?

Thanks.

-- 
tejun
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help