On Tue, 2014-08-05 at 19:48 -0500, Scott Wood wrote:
I'll do s/mmu_allcpus/this_mmu/ but early_init_mmu() needs to do things
both before and after early_init_mmu_common(). Do you want two new
functions (before and after) or is it OK to just rename
early_init_mmu_allcpus() and put a comment before early_init_mmu()
saying it's just for the boot cpu?
Do we really need that before/after ? The "after" code is the linear
mapping setup but does it rely on the MAS4 setting done above ?
Otherwise you can do before/after using a separate function
mmu_set_linear_map()
Always nicer to break down too large functions anyway.
Cheers,
Ben.