Thread (32 messages) 32 messages, 8 authors, 2013-08-29

Re: [RFC PATCH 3/4] powerpc: refactor of_get_cpu_node to support other architectures

From: Sudeep KarkadaNagesha <hidden>
Date: 2013-08-16 12:44:55
Also in: linux-arm-kernel, linux-pm, lkml

On 16/08/13 13:32, Benjamin Herrenschmidt wrote:
On Fri, 2013-08-16 at 09:48 +0100, Sudeep KarkadaNagesha wrote:
=20
quoted
quoted
Naming is a bit gross. You might want to make it clearer that
we are talking about CPU IDs in the device-tree here.
Any particular preference to the name or just a note is sufficient.
Also unlike PPC, in ARM we don't set hard processor id value based
values read from device tree. DT must contain the values matching to the
hardware ID registers.
=20
This is exactly the same on ppc. We don't "set" HW values. The
device-tree content matches the HW internals. Some processors have a
"PIR" register as well which contains the HW value, in this case the
device-tree must contain the same value as the PIR on that processor.
=20
Ok, I misread the function 'set_hard_smp_processor_id' function.
BTW, you didn't mention if you are OK by just have this clearly
documented in the function and/or you have any preference/better name.

I will send the next version based on that. I have even compile tested
:) now on PPC.

Regards,
Sudeep
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help