Re: linux-next: manual merge of the kvm-ppc tree with the powerpc-merge tree
flat view
From: Scott Wood <hidden>
Date: 2012-10-11 16:33:55
Also in:
linux-next, lkml
On 10/11/2012 10:56:51 AM, Alexander Graf wrote:
=20 On 11.10.2012, at 17:50, Scott Wood wrote: =20quoted
On 10/11/2012 08:04:58 AM, Alexander Graf wrote:quoted
On 11.10.2012, at 05:32, Tabi Timur-B04825 wrote:quoted
On Wed, Oct 10, 2012 at 9:47 PM, Stephen Rothwell =20[off-list ref] wrote:quoted
quoted
quoted
quoted
Commit 549d62d889b4 ("KVM: PPC: use definitions in epapr header for hcalls") from the kvm-ppc tree added an include of =20asm/epapr_hcall.hquoted
quoted
quoted
quoted
to the user visible part of asm/kvm_para.h so asm/epapr_hcall.h =20became aquoted
quoted
quoted
quoted
user visible header file.Any real user-space code that tries to call any of the functions =20inquoted
quoted
quoted
epapr_hcall.h will cause an exception.Actually it'll cause a linker error, as of the "Don't use hardcoded =20opcode for ePAPR hcall invocation" patch.quoted
quoted
quoted
Claiming that kernel header files that KVM needs are suddenly user-space header files doesn't make much sense to me, but I =20guessquoted
quoted
quoted
it's not my decision.This is about kvm_host.h, which is the part that is exported to =20user space. It usually contains constants and structs that are =20 required for the API.quoted
s/kvm_host/kvm_para/ I'm not sure anything in kvm_para.h or epapr_hcalls.h would be of =20use to userspace, but it would be of use to the guest OS, so it's =20 still not kernel-internal.quoted
The variable externs should be #ifdef __KERNEL__ as David points =20out. The asm stuff could still be useful in a guest OS if the guest =20 provides epapr_hypercall_start. =20 I don't think we should worry about guest kernel code potentially =20 having use for this. Let's make the user space headers be great for =20 user space usage, not for guest code usage :).
Well, that asm stuff started out as a guest header (from Freescale's =20
Topaz hypervisor), not a Linux header. :-)
-Scott=