On Thu, Sep 27, 2012 at 11:50 PM, Yasuaki Ishimatsu
[off-list ref] wrote:
Hi Chen,
2012/09/28 11:22, Ni zhan Chen wrote:
quoted
On 09/05/2012 05:25 PM, wency@cn.fujitsu.com wrote:
quoted
From: Yasuaki Ishimatsu <redacted>
remove_memory() only try to offline pages. It is called in two cases:
1. hot remove a memory device
2. echo offline >/sys/devices/system/memory/memoryXX/state
In the 1st case, we should also change memory block's state, and notify
the userspace that the memory block's state is changed after offlining
pages.
So rename remove_memory() to offline_memory()/offline_pages(). And in
the 1st case, offline_memory() will be used. The function
offline_memory()
is not implemented. In the 2nd case, offline_pages() will be used.
But this time there is not a function associated with add_memory.
To associate with add_memory() later, we renamed it.
Then, you introduced bisect breakage. It is definitely unacceptable.
NAK.