[PATCH 6/7][TRIVIAL][resend] mm: cleanup page reclaim comment error

Subsystems: memory management, memory management - mglru (multi-gen lru), memory management - reclaim, the rest

STALE5229d REVIEWED: 4 (2M)

3 review trailers.

2 messages, 2 authors, 2012-06-15 · open the first message on its own page

[PATCH 6/7][TRIVIAL][resend] mm: cleanup page reclaim comment error

From: Wanpeng Li <hidden>
Date: 2012-06-15 13:20:18

From: Wanpeng Li <redacted>

Since there are five lists in LRU cache, the array nr in get_scan_count
should be:

nr[0] = anon inactive pages to scan; nr[1] = anon active pages to scan
nr[2] = file inactive pages to scan; nr[3] = file active pages to scan

Signed-off-by: Wanpeng Li <redacted>
Acked-by: KOSAKI Motohiro <redacted>
Acked-by: Minchan Kim <minchan@kernel.org>
Reviewed-by: Rik van Riel <redacted>

---
 mm/vmscan.c |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mm/vmscan.c b/mm/vmscan.c
index eeb3bc9..ed823df 100644
--- a/mm/vmscan.c
+++ b/mm/vmscan.c
@@ -1567,7 +1567,8 @@ static int vmscan_swappiness(struct scan_control *sc)
  * by looking at the fraction of the pages scanned we did rotate back
  * onto the active list instead of evict.
  *
- * nr[0] = anon pages to scan; nr[1] = file pages to scan
+ * nr[0] = anon inactive pages to scan; nr[1] = anon active pages to scan
+ * nr[2] = file inactive pages to scan; nr[3] = file active pages to scan
  */
 static void get_scan_count(struct lruvec *lruvec, struct scan_control *sc,
 			   unsigned long *nr)
-- 
1.7.9.5

Re: [PATCH 6/7][TRIVIAL][resend] mm: cleanup page reclaim comment error

From: Johannes Weiner <hannes@cmpxchg.org>
Date: 2012-06-15 15:02:27

On Fri, Jun 15, 2012 at 09:19:45PM +0800, Wanpeng Li wrote:
quoted hunk
From: Wanpeng Li <redacted>

Since there are five lists in LRU cache, the array nr in get_scan_count
should be:

nr[0] = anon inactive pages to scan; nr[1] = anon active pages to scan
nr[2] = file inactive pages to scan; nr[3] = file active pages to scan

Signed-off-by: Wanpeng Li <redacted>
Acked-by: KOSAKI Motohiro <redacted>
Acked-by: Minchan Kim <minchan@kernel.org>
Reviewed-by: Rik van Riel <redacted>

---
 mm/vmscan.c |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mm/vmscan.c b/mm/vmscan.c
index eeb3bc9..ed823df 100644
--- a/mm/vmscan.c
+++ b/mm/vmscan.c
@@ -1567,7 +1567,8 @@ static int vmscan_swappiness(struct scan_control *sc)
  * by looking at the fraction of the pages scanned we did rotate back
  * onto the active list instead of evict.
  *
- * nr[0] = anon pages to scan; nr[1] = file pages to scan
+ * nr[0] = anon inactive pages to scan; nr[1] = anon active pages to scan
+ * nr[2] = file inactive pages to scan; nr[3] = file active pages to scan
  */
Does including this in the comment have any merit in the first place?
We never access nr[0] or nr[1] etc. anywhere with magic numbers.  It's
a local function with one callsite, the passed array is declared and
accessed exclusively by what is defined in enum lru_list, where is the
point in repeating the enum items?.  I'd rather the next change to
this comment would be its removal.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help