Thread (37 messages) 37 messages, 5 authors, 2012-07-02

Re: [RFC PATCH 1/12] memory-hotplug : rename remove_memory to offline_memory

From: David Rientjes <rientjes@google.com>
Date: 2012-06-27 06:10:38
Also in: linux-acpi, linux-mm, lkml

On Wed, 27 Jun 2012, Yasuaki Ishimatsu wrote:
remove_memory() does not remove memory but just offlines memory. The patch
changes name of it to offline_memory().
The kernel is never going to physically remove the memory itself, so I 
don't see the big problem with calling it remove_memory().  If you're 
going to change it to offline_memory(), which is just as good but not 
better, then I'd suggest changing add_memory() to online_memory() for 
completeness.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help