Thread (4 messages) flat view 4 messages, 4 authors, 2012-01-27

Re: [PATCH] mtd/nand:Fix wrong usage of is_blank() in fsl_ifc_run_command

From: Artem Bityutskiy <dedekind1@gmail.com>
Date: 2012-01-27 13:13:30

On Wed, 2012-01-18 at 09:43 +0530, Prabhakar Kushwaha wrote:
Freescale IFC NAND Machine calculates ECC on 512byte sector and same is used in
fsl_ifc_run_command() during ECC status verification. Also this sector is passed
to is_blank() for blank checking. It is wrong at first place because
is_blank()'s implementation checks for Page size and OOB area size. 
is_blank() should be called per page for main and OOB area verification.

Variables name are redefined to avoid confusion between buffer and ecc sector.

Signed-off-by: Poonam Aggrwal <redacted>
Signed-off-by: Scott Wood <redacted>
Signed-off-by: Prabhakar Kushwaha <redacted>
The driver is not in 3.3-rc1, so I skip this patch.

-- 
Best Regards,
Artem Bityutskiy

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help