Thread (32 messages) 32 messages, 5 authors, 2011-12-05

Re: [PATCH v3 02/10] powerpc: Consolidate mpic_alloc() OF address translation

From: Kumar Gala <hidden>
Date: 2011-12-03 15:53:47

On Dec 2, 2011, at 10:27 AM, Kyle Moffett wrote:
Instead of using the open-coded "reg" property lookup and address
translation in mpic_alloc(), directly call of_address_to_resource().
This includes various workarounds for special cases which the naive
of_address_translate() does not.
=20
Afterwards it is possible to remove the copiously copy-pasted calls to
of_address_translate() from the 85xx/86xx/powermac platforms.
=20
Signed-off-by: Kyle Moffett <redacted>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Paul Mackerras <redacted>
Cc: Grant Likely <redacted>
Cc: Kumar Gala <redacted>
---
arch/powerpc/platforms/85xx/corenet_ds.c  |    9 +----
arch/powerpc/platforms/85xx/ksi8560.c     |    9 +----
arch/powerpc/platforms/85xx/mpc8536_ds.c  |    9 +----
arch/powerpc/platforms/85xx/mpc85xx_ads.c |    9 +----
arch/powerpc/platforms/85xx/mpc85xx_cds.c |    9 +----
arch/powerpc/platforms/85xx/mpc85xx_ds.c  |   11 +----
arch/powerpc/platforms/85xx/mpc85xx_mds.c |    9 +----
arch/powerpc/platforms/85xx/mpc85xx_rdb.c |   11 +----
arch/powerpc/platforms/85xx/p1010rdb.c    |    9 +----
arch/powerpc/platforms/85xx/p1022_ds.c    |    9 +----
arch/powerpc/platforms/85xx/p1023_rds.c   |    9 +----
arch/powerpc/platforms/85xx/sbc8548.c     |    9 +----
arch/powerpc/platforms/85xx/sbc8560.c     |    9 +----
arch/powerpc/platforms/85xx/socrates.c    |    9 +----
arch/powerpc/platforms/85xx/stx_gp3.c     |    9 +----
arch/powerpc/platforms/85xx/tqm85xx.c     |    9 +----
arch/powerpc/platforms/85xx/xes_mpc85xx.c |    9 +----
arch/powerpc/platforms/86xx/pic.c         |    4 +-
arch/powerpc/platforms/powermac/pic.c     |    8 +---
arch/powerpc/sysdev/mpic.c                |   61 =
++++++++++++++++-------------
20 files changed, 55 insertions(+), 175 deletions(-)
What about cleaning up:

arch/powerpc/platforms/chrp/setup.c:    chrp_mpic =3D mpic_alloc(np, =
opaddr, MPIC_PRIMARY,
arch/powerpc/platforms/embedded6xx/holly.c:     mpic =3D =
mpic_alloc(tsi_pic, mpic_paddr,
arch/powerpc/platforms/embedded6xx/linkstation.c:       mpic =3D =
mpic_alloc(dnp, paddr, MPIC_PRIMARY | MPIC
arch/powerpc/platforms/embedded6xx/mpc7448_hpc2.c:      mpic =3D =
mpic_alloc(tsi_pic, mpic_paddr,
arch/powerpc/platforms/embedded6xx/storcenter.c:        mpic =3D =
mpic_alloc(dnp, paddr, MPIC_PRIMARY | MPIC
arch/powerpc/platforms/maple/setup.c:   mpic =3D mpic_alloc(mpic_node, =
openpic_addr, flags,
arch/powerpc/platforms/pasemi/setup.c:  mpic =3D mpic_alloc(mpic_node, =
openpic_addr,
arch/powerpc/platforms/pseries/setup.c: mpic =3D =
mpic_alloc(pSeries_mpic_node, openpic_addr,

Seems like we should be able to remove the 'phys_addr' argument =
altogether.

- k=
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help