Re: [PATCH] irq: move some interrupt arch_* functions into struct irq_chip.
From: Eric W. Biederman <hidden>
Date: 2010-03-10 19:16:15
Also in:
lkml
Yinghai Lu [off-list ref] writes:
On 03/10/2010 04:51 AM, Ian Campbell wrote:quoted
On Wed, 2010-03-10 at 12:06 +0000, Yinghai Lu wrote:quoted
On Wed, Mar 10, 2010 at 2:55 AM, [off-list ref] wrote:quoted
From: Ian Campbell <redacted> Move arch_init_copy_chip_data and arch_free_chip_data into function pointers in struct irq_chip since they operate on irq_desc->chip_data. arch_init_chip_data cannot be moved into struct irq_chip at this time because irq_desc->chip is not known at the time the irq_desc is setup. For now rename arch_init_chip_data to arch_init_irq_desc (for PowerPC, the only other user, whose usage better matches the new name) and on x86 convert arch_init_chip_data to ioapic_init_chip_data and call this whenever the IO APIC code allocates a new IRQ. I've retained the chip_data behaviour for uv_irq although it isn't clear to me if these interrupt types support migration or how closely related to the APIC modes they really are. If it weren't for this the ioapic_{init,copy,free}_chip_data functions could be static to io_apic.c. I've tested by booting on a 64 bit system, but it's not clear to me what actions I need to take to actually exercise some of these code paths.can you just add another pointer field in irq_desc? some kind of *irq_info etc.I think I don't understand what you are suggesting. There is already a pointer for irq_chip specific use i.e. irq_desc->chip_data. This patchset is just about ensuring that the field really is available to any chip implementation rather than just assuming it is always used for the acpi chip types (on x86 at least). Does adding a second pointer with the same (intended?) semantics as the existing one buy us anything?#ifdef CONFIG_INTR_REMAP struct irq_2_iommu *irq_2_iommu; #endif struct irq_chip *chip; struct msi_desc *msi_desc; we already have that for irq_2_iommu and msi_desc
Those are at different levels of the hierarchy. Adding another pointer for Xen is like having a different iommu and so adding another pointer to handle that kind of iommu. Eric