On Tue, 2010-01-12 at 23:43 -0700, Grant Likely wrote:
On Tue, Dec 22, 2009 at 6:17 AM, Michael Ellerman
[off-list ref] wrote:
quoted
On Tue, 2009-12-22 at 18:54 +0800, Jeremy Kerr wrote:
quoted
Hi Michael,
quoted
quoted
void early_init_dt_setup_initrd_arch(unsigned long start,
unsigned long end);
arch_early_init_dt_setup_initrd() makes more sense to me, but ..
<foo>_arch has been the general convention for arch-specific hooks in
drivers/of/.
Yuck, doh, guess I should have read those patches before they went in :)
It's not necessarily permanent. My first goal is to get the common
code merged. Then I want to look closely at it for patterns and
refactor how the common code calls out to arch specific hooks (or
maybe turn it around and have arch code calling out to the common
bits).
Sure, no biggy. There is lots of precedent for arch hooks to be called
arch_foo() or topic_arch_foo(), but it's not the end of the world.
cheers