[PATCH] rtc-ds1374: Rename device to just "ds1374"

STALE6670d

3 messages, 2 authors, 2008-06-04 · open the first message on its own page

[PATCH] rtc-ds1374: Rename device to just "ds1374"

From: Alessandro Zummo <hidden>
Date: 2008-06-04 13:20:03

From: Jean Delvare <redacted>


Change the name of the device from "rtc-ds1374" to just "ds1374", to
match what all other RTC drivers do. I seem to remember that this name
was chosen to avoid possible confusion with an older ds1374 driver,
but that driver was removed 3 months ago.

Signed-off-by: Jean Delvare <redacted>
Signed-off-by: Alessandro Zummo <redacted>

---
Patch already sent on:
 * 2008-04-30

 arch/powerpc/sysdev/fsl_soc.c |    2 +-
 drivers/of/of_i2c.c           |    1 -
 drivers/rtc/rtc-ds1374.c      |    2 +-
 3 files changed, 2 insertions(+), 3 deletions(-)
--- linux-2.6.26-rc0.orig/arch/powerpc/sysdev/fsl_soc.c	2008-04-29 22:55:32.000000000 +0200
+++ linux-2.6.26-rc0/arch/powerpc/sysdev/fsl_soc.c	2008-04-30 08:32:43.000000000 +0200
@@ -432,7 +432,7 @@ static struct i2c_driver_device i2c_devi
 	{"dallas,ds1339",  "ds1339"},
 	{"dallas,ds1340",  "ds1340"},
 	{"stm,m41t00",     "m41t00"},
-	{"dallas,ds1374",  "rtc-ds1374"},
+	{"dallas,ds1374",  "ds1374"},
 };
 
 static int __init of_find_i2c_driver(struct device_node *node,
--- linux-2.6.26-rc0.orig/drivers/of/of_i2c.c	2008-04-29 07:41:15.000000000 +0200
+++ linux-2.6.26-rc0/drivers/of/of_i2c.c	2008-04-30 08:32:38.000000000 +0200
@@ -21,7 +21,6 @@ struct i2c_driver_device {
 };
 
 static struct i2c_driver_device i2c_devices[] = {
-	{ "dallas,ds1374", "rtc-ds1374" },
 };
 
 static int of_find_i2c_driver(struct device_node *node,
--- linux-2.6.26-rc0.orig/drivers/rtc/rtc-ds1374.c	2008-04-29 23:07:07.000000000 +0200
+++ linux-2.6.26-rc0/drivers/rtc/rtc-ds1374.c	2008-04-30 08:32:33.000000000 +0200
@@ -42,7 +42,7 @@
 #define DS1374_REG_TCR		0x09 /* Trickle Charge */
 
 static const struct i2c_device_id ds1374_id[] = {
-	{ "rtc-ds1374", 0 },
+	{ "ds1374", 0 },
 	{ }
 };
 MODULE_DEVICE_TABLE(i2c, ds1374_id);


--

 Best regards,

 Alessandro Zummo,
  Tower Technologies - Torino, Italy

  http://www.towertech.it

Re: [PATCH] rtc-ds1374: Rename device to just "ds1374"

From: Kumar Gala <hidden>
Date: 2008-06-04 13:41:04

On Jun 4, 2008, at 8:05 AM, Alessandro Zummo wrote:
From: Jean Delvare <redacted>


Change the name of the device from "rtc-ds1374" to just "ds1374", to
match what all other RTC drivers do. I seem to remember that this name
was chosen to avoid possible confusion with an older ds1374 driver,
but that driver was removed 3 months ago.

Signed-off-by: Jean Delvare <redacted>
Signed-off-by: Alessandro Zummo <redacted>
Acked-by: Kumar Gala <redacted>

Is this for 2.6.26?  also which tree is this going via?

- k

Re: [PATCH] rtc-ds1374: Rename device to just "ds1374"

From: Alessandro Zummo <hidden>
Date: 2008-06-04 13:45:02

On Wed, 4 Jun 2008 08:40:46 -0500
Kumar Gala [off-list ref] wrote:
quoted
Signed-off-by: Jean Delvare <redacted>
Signed-off-by: Alessandro Zummo <redacted>
Acked-by: Kumar Gala <redacted>

Is this for 2.6.26?  also which tree is this going via?
 directly via akpm, I'd say.
 
-- 

 Best regards,

 Alessandro Zummo,
  Tower Technologies - Torino, Italy

  http://www.towertech.it
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help