RE: [PATCH] booting-without-of: add Xilinx uart 16550.
From: Stephen Neuendorffer <hidden>
Date: 2008-02-15 21:40:23
quoted
Instead of attempting to come up with a generic description of this, I recommend just naming it after the actual device
instance;
quoted
something like compatible=3D"xlnx,opb-uart16550";=20 Well, that means that we'll need a to add a code which "glues" the
chip to
8250.c driver... well, of_serial.c could be that glue layer if we add
to it
the ability to recognize Xilinx UART... well, legacy_serial.c could be
taught
that trick too...
Well, we could also add the new compatible, but still claim"ns16550"
compatibility...
This actually makes more sense to me... I'd rather have the code set
the reg-shift than have it explicitly set in the device tree anyway.
The compatibility set should include (at the least):
opb_uart16550_v1_00_c
opb_uart16550_v1_00_d
opb_uart16550_v1_00_e
plb_uart16550_v1_00_c
xps_uart16550_v1_00_a
I think this is somewhat independent of Sergei's arguments that generic
ns16550 devices should allow having a reg-shift set....
Steve