quoted
quoted
quoted
+ MPIC: interrupt-controller@d {
+ device_type = "open-pic";
device_type = "interrupt-controller".
Not according to the binding in booting-without-of.txt
My understanding here, though possibly flawed, is that the current
implementation has "open-pic" but _should_ have "interrupt-controller"
as that is the officially correct name.
I _think_ this means we need a transitional period where we update
the code to look for "interrupt-controller", and obsoletedly, looks
for the "open-pic", while we transition to the new, correct name.
I'm just betting that if I'm wrong Segher will tell me! :-)
You're wrong :-)
The kernel shouldn't look at device_type at all.
Segher