quoted
quoted
+ ide@f0000000 {
+ compatible = "mmio-ide";
+ device_type = "ide";
quoted
Why not "ata"?
The hardware is called (E)IDE, the protocol is called ATA.
Or that's what I was told -- I think there's some historic
revisionism involved, too.
Also, what mmio-ide in the compat properly means in the context of
ide_platform which is able to handle both port and memory mapped IDE.
I think
we must get rid with this crap, and since this IDE register mapping is
pretty
much board specific, call it something like "mpc8349emitx-ide" instead.
"mmio-ide" simply is not specific enough. The device_type
should go, too.
If this IDE interface is board-specific, thee "compatible"
property should include the board vendor name and board
name. Oh, that's what "emitx" tries to do -- it could be
a bit clearer perhaps ;-)
Segher