On Wed, 25 Jul 2007 21:43:12 +0400
Vitaly Bordug [off-list ref] wrote:
Gianfar driver is now able to work without real phy subnode,
that is necessary to cope with fixed-link situation, when
SoC is connected to the Ethernet inteface or embedded switch
without any PHY. In this case, fixed-speed property will
describe such a situation for gianfar driver.
The property is in form <duplexity speed>
Signed-off-by: Vitaly Bordug <redacted>
---
arch/powerpc/sysdev/fsl_soc.c | 39 +++++++++++++++++++++++----------------
drivers/net/gianfar.c | 17 ++++++++++++++---
please run this through checkpatch.pl until it passes.
<snip>
+ bus_id = of_get_property(np, "fixed_speed",NULL);
hyphens are preferred for new properties. Plus, isn't fixed-link a
better name? unless you instead want to put speed first and make
duplexity an optional second, or possibly even a string.
Also, can we get this new property documented in b-w-of in a separate
patch?
Kim