So, like, the other day Segher Boessenkool mumbled:
quoted
+/ {
+ model = "StorCenter";
If you can find a real model number, put it in here, instead.
Yep, "StorCenter" is it. No model numer/name beyond that.
quoted
+ compatible = "storcenter";
Needs a manufacturer name in there.
Right. Will use:
compatible = "iomega,storcenter"
quoted
+ PowerPC,603e { /* Really 8241 */
So say "PowerPC,8241@0", or "PowerPC,e300@0" (or whatever
the CPU core in there is), or simply "cpu@0", following
the generic naming recommended practice.
Well, its the 8241 SoC with a 603e core... (This is
the same phrase currently being used on the Kurobox.)
I'll use:
PowerPC,8241@0 }
quoted
+ bus-frequency = <0>;
Is this filled in anywhere? Please document that, if so.
Right. boot{loader,wrapper}
quoted
+ soc10x {
Bad name. Where is the binding for this? I don't think
I saw it before.
It's what is being used, again, by the Kurobox. I understand
that doesn't make it "right", just precedented by now.
How about "soc8241@80000000" instead?
That would be similar to:
soc8641@f8000000 {
and
soc8272@f0000000 {
quoted
+ store-gathering = <0>; /* 0 == off, !0 == on */
Don't define this as "!0", but as "1".
OK.
quoted
+ i2c@fdf03000 {
+ device_type = "i2c";
No device_type, there is no I2C binding.
Right.
quoted
+ compatible = "fsl-i2c";
Needs to be more specific.
Hmmm... Not sure what to use here then. There are many
existing examples using "fsl-i2c" already. Granted, we've
established that they could be wrong... Should this be
more like this?:
compatible = "fsl,mpc8241-i2c", "fsl-i2c";
quoted
+ mpic: pic@fdf40000 {
interrupt-controller@fdf40000
OK.
quoted
+ pci@fe800000 {
+ clock-frequency = <d# 100000000>; /* Hz */
100MHz PCI? Interesting.
Good point. 66666666 seems more likely...
Thanks for the review and help here!
jdl
Jon Loeliger wrote:
How about "soc8241@80000000" instead?
That would be similar to:
soc8641@f8000000 {
and
soc8272@f0000000 {
How about just "soc@80000000"? Those model numbers in the names are a
PITA to find from limited functionality environments such as the
bootwrapper, require things like stdout-path to be different on every
soc, and don't comply with the generic names recommendation.
-Scott
quoted
quoted
+ compatible = "storcenter";
Needs a manufacturer name in there.
Right. Will use:
compatible = "iomega,storcenter"
Okido.
quoted
quoted
+ PowerPC,603e { /* Really 8241 */
So say "PowerPC,8241@0", or "PowerPC,e300@0" (or whatever
the CPU core in there is), or simply "cpu@0", following
the generic naming recommended practice.
Well, its the 8241 SoC with a 603e core... (This is
the same phrase currently being used on the Kurobox.)
I'll use:
PowerPC,8241@0 }
That might be best yes.
quoted
quoted
+ soc10x {
Bad name. Where is the binding for this? I don't think
I saw it before.
It's what is being used, again, by the Kurobox. I understand
that doesn't make it "right", just precedented by now.
Sure, just trying to trick you into documenting it ;-)
How about "soc8241@80000000" instead?
soc@ like suggested by Scott seems just fine.
quoted
quoted
+ compatible = "fsl-i2c";
Needs to be more specific.
Hmmm... Not sure what to use here then. There are many
existing examples using "fsl-i2c" already. Granted, we've
established that they could be wrong... Should this be
more like this?:
compatible = "fsl,mpc8241-i2c", "fsl-i2c";
That looks good yes. Or if the kernel side code for
recognising fsl,mpc8241-i2c gets merged in time, you
can leave out fsl-i2c from your device tree completely.
Segher
On Jul 18, 2007, at 11:19 AM, Segher Boessenkool wrote:
quoted
quoted
quoted
+ compatible = "storcenter";
Needs a manufacturer name in there.
Right. Will use:
compatible = "iomega,storcenter"
Okido.
quoted
quoted
quoted
+ PowerPC,603e { /* Really 8241 */
So say "PowerPC,8241@0", or "PowerPC,e300@0" (or whatever
the CPU core in there is), or simply "cpu@0", following
the generic naming recommended practice.
Well, its the 8241 SoC with a 603e core... (This is
the same phrase currently being used on the Kurobox.)
I'll use:
PowerPC,8241@0 }
That might be best yes.
quoted
quoted
quoted
+ soc10x {
Bad name. Where is the binding for this? I don't think
I saw it before.
It's what is being used, again, by the Kurobox. I understand
that doesn't make it "right", just precedented by now.
Sure, just trying to trick you into documenting it ;-)
quoted
How about "soc8241@80000000" instead?
soc@ like suggested by Scott seems just fine.
quoted
quoted
quoted
+ compatible = "fsl-i2c";
Needs to be more specific.
Hmmm... Not sure what to use here then. There are many
existing examples using "fsl-i2c" already. Granted, we've
established that they could be wrong... Should this be
more like this?:
compatible = "fsl,mpc8241-i2c", "fsl-i2c";
That looks good yes. Or if the kernel side code for
recognising fsl,mpc8241-i2c gets merged in time, you
can leave out fsl-i2c from your device tree completely.
Hmm, there are really only two fsl,i2c controllers. The one we call
fsl-i2c, and the cpm-i2c controller.
So I'd prefer we don't use fsl,mpc8241-i2c. I'd suggest fsl,ppc-i2c
or something like that.
- k
quoted
quoted
compatible = "fsl,mpc8241-i2c", "fsl-i2c";
That looks good yes. Or if the kernel side code for
recognising fsl,mpc8241-i2c gets merged in time, you
can leave out fsl-i2c from your device tree completely.
Hmm, there are really only two fsl,i2c controllers. The one we
call fsl-i2c, and the cpm-i2c controller.
So I'd prefer we don't use fsl,mpc8241-i2c. I'd suggest fsl,ppc-
i2c or something like that.
The actual name doesn't matter much, as long as it is "unique
enough"; a name that matches a name already in use in real life
is preferred; normally the name is just the name of the first
device that had this specific programming interface.
But choose whatever you want. It is a good idea to always
put the exact name of the specific device in there, too, btw,
so you'd end up with "fsl,mpc8241-i2c", "fsl,ppc-i2c" if your
suggestion is accepted.
Segher