@@ -412,6 +412,18 @@ int ps3_free_spe_irq(unsigned int virq)return0;}+intps3_alloc_irq(enumps3_cpu_bindingcpu,unsignedlongoutlet,+unsignedint*virq)+{+returnps3_connect_irq(cpu,outlet,virq);+}++intps3_free_irq(unsignedintvirq)+{+ps3_disconnect_irq(virq);+return0;+}+#define PS3_INVALID_OUTLET ((irq_hw_number_t)-1)#define PS3_PLUG_MAX 63---ps3-linux-dev.orig/include/asm-powerpc/ps3.h+++ps3-linux-dev/include/asm-powerpc/ps3.h
@@ -163,6 +163,9 @@ int ps3_free_vuart_irq(unsigned int virqintps3_alloc_spe_irq(enumps3_cpu_bindingcpu,unsignedlongspe_id,unsignedintclass,unsignedint*virq);intps3_free_spe_irq(unsignedintvirq);+intps3_alloc_irq(enumps3_cpu_bindingcpu,unsignedlongoutlet,+unsignedint*virq);+intps3_free_irq(unsignedintvirq);/* lv1 result codes */
I'm not too fan of this... those 2 functions do strictly -nothing- other
than export the ones they call (not even changing arguments).
So why not export ps3_connect_irq / ps3_disconnect_irq directly ?
Ben.
I'm not too fan of this... those 2 functions do strictly -nothing- other
than export the ones they call (not even changing arguments).
So why not export ps3_connect_irq / ps3_disconnect_irq directly ?
You're right. Originally they were all but trivial wrappers, but the recent
interrupt improvements have changed this.
Do you have a preference which names to keep?
1. ps3_connect_irq() and ps3_disconnect_irq() resemble the LV1 calls they
make,
2. ps3_alloc_irq() and ps3_free_irq() resemble the other
ps3_{alloc,free}_*_irq() names.
Personally I favor the latter.
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- Sony Network and Software Technology Center Europe (NSCE)
Geert.Uytterhoeven@sonycom.com ------- The Corporate Village, Da Vincilaan 7-D1
Voice +32-2-7008453 Fax +32-2-7008622 ---------------- B-1935 Zaventem, Belgium
I'm not too fan of this... those 2 functions do strictly -nothing- other
than export the ones they call (not even changing arguments).
So why not export ps3_connect_irq / ps3_disconnect_irq directly ?
You're right. Originally they were all but trivial wrappers, but the recent
interrupt improvements have changed this.
Do you have a preference which names to keep?
1. ps3_connect_irq() and ps3_disconnect_irq() resemble the LV1 calls they
make,
2. ps3_alloc_irq() and ps3_free_irq() resemble the other
ps3_{alloc,free}_*_irq() names.
I think ps3_connect_irq() and ps3_disconnect_irq() are not consistent with
the existing routines, so I would perfer not to use those. I'll post a new
patch that makes this change.
-Geoff
From: Benjamin Herrenschmidt <benh@kernel.crashing.org> Date: 2007-01-26 02:48:52
Do you have a preference which names to keep?
1. ps3_connect_irq() and ps3_disconnect_irq() resemble the LV1 calls they
make,
2. ps3_alloc_irq() and ps3_free_irq() resemble the other
ps3_{alloc,free}_*_irq() names.
Personally I favor the latter.
Well, I think connect is a better illustration of the semantic. They
don't only alloc/free, since also connect. I think alloc/free is
actually confusing. Or maybe ps3_alloc_and_connect_irq() :-)
Ben.