quoted
Some firmwares have "pcie" for the "name" property of the CPC945 PCI
Express host bridge. Check for "pcie" in addition to "pci" so we
don't miss it.
1275 (draft) supplement for PCI Express use 'pciex'. 'Some firmware'
should be changed instead, if possible.
Nah, the draft should be changed, "pciex" is an absolutely
horrible name :-) The draft contains a few serious bugs
btw, I hope no one implements this as-is :-)
See http://playground.sun.com/1275/bindings/pci/pci-express.txt
That's also what pseries and rtas_pci uses.
Apple uses plain "pci". Using the "device_type" and the
"compatible" property works fine everywhere -- *except*
for implementations following this broken draft spec (the
draft doesn't even define a value for "device_type"; also
it prohibits declaring in the "compatible" property that
a device is backward compatible to some plain old PCI
device).
Segher