Thread (9 messages) 9 messages, 2 authors, 2006-11-08

Re: [PATCH] adding ROM chips to device tree: respin

flat view

From: Sergei Shtylyov <hidden>
Date: 2006-11-07 22:40:40

Hello.

Vitaly Wool wrote:
quoted
   We don't have any actual registers (at least "physmap" doesn't know about them anyway) I think, just a memory range. What registers are you talking about?
We do have registers there, in query mode. The CFI registers.
   Aren't they accessed thru the range we're giving to the mapping layer? What else do you need? Who cares about the exact offsets at the mapping level (or at the level of the bus)?
quoted
quoted
Okay, probably we can go you way naming of_device by what it's
compatible with. So that "physmap" compatible would be called
"physmap-flash", "nand"-compatible would be called "nand-flash" etc.
quoted
   Actually, Generic Names spec tells to use the most generic user-parsable names, just like I used initally ("flash")...
quoted
quoted
Does that work for you?
quoted
   No. Getting rid of "physmap" completely and using of_find_node_by_type() does. :-)
That's effectively what I'm talking about. Find the device by type and
register it with the name which depends on what it's compatible with.
   I stand enlightened. It have finally occured to me that this of_device stuff wasn't worth the effort of using it and moving the code into drivers/mtd/. This move doesn't buy you much -- you still have to walk the device tree stupidly in search for the "known" devices... unless you're making up the names for of_platform bus like this. And what for? Those names aren't used to select the correct driver anyway... Crap. :-(
   We could also try using "device_type" or "name" properties to name the of_device -- this name doesn't matter much anyway...
Vitaly
WBR, Sergei
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help