On Fri, 11 August 2006 09:28:26 +0200, Thomas Klein wrote:
Michael Neuling wrote:
quoted
quoted
quoted
quoted
+static inline u32 map_swqe_size(u8 swqe_enc_size)
+static inline u32|map_rwqe_size(u8 rwqe_enc_size)
Agreed. Functions were replaced by a single map_wqe_size() function.
Just a general thing, try to avoid having two identifiers that are
near-100% identical. As seen in this thread, they are _very_ easy to
confuse.
Ime, there are two methods to avoid this. One is to make the
identifiers longer, something like "map_seek_wqe_size" and
"map_read_wqe_size". The other is to make them shorter, just "s" and
"r" is less confusing than the above.
Which method works best depends on many things, including personal
taste.
Jörn
--
And spam is a useful source of entropy for /dev/random too!
-- Jasmine Strong