On Thu, Jun 22, 2006 at 03:56:09PM -0700, Mike Kravetz wrote:
This version addresses all comments received except Arnd's issue
with an #ifdef for each function in the assembly file.
I was thinking of changing the names of all the assembly routines from
plpar_hcall_*() to plpar_hcall_*_asm(). The instrumented version of the
routines would be named plpar_hcall_*_inst(). Then, the header file
would contain definitions such as:
#ifdef CONFIG_HCALL_STATS
#define plpar_hcall_*() plpar_hcall_*_inst()
.
#else
#define plpar_hcall_*() plpar_hcall_*_asm()
.
#endif
Is that any better than all the individual #ifdefs in the .S file? Is it
still too ugly?
I'm open to any suggestions.
Thanks,
--
Mike